PDA

View Full Version : Got my Cobra...!!!



Goldie
24-03-01, 05:30 PM
I went and collected my Cobra yesterday from London. Very eventful trip through London on a friday with very wide car transporter trailer attached to back of my own car.

Bought a chassis, body and other bits from someone who started but stopped after the running gear was fitted. Previous owner also primed the body ready for painting.

The person I was buying this from had a Ford 390 fitted which I did not want so I got American Speed to build me a Chevy 350 with T10 geabox. I had the car delivered to them as they were very close and they removed the 390 and made new engine and gearbox mounts and mounted the new 350 and gearbox onto the chassis.

They also took out the steering rack and column which did not work and put in Jag column and Escort rack.

I need to remove the body, tidy up the chassis and running gear, and then dismantle the running gear and brakes to give them a full overhaul and checkout.

I took some photos and entered some details into the diary and gallery of my website. I just though if there are any other AD427 owners out there, maybe they would like to follow my build or even give me some advice. (Its the first time I have done something like this)... There is a lot of work ahead of me and I dont have an instruction manual...!!!

Fingers Crossed.....!!!!!!

Goldie...

Goldie
24-03-01, 05:32 PM
Oops....

Forgot to mention my site is http://www.ad427.co.uk

Goldie...

RigMan
25-03-01, 09:14 AM
Congratulations and good luck!

Rig.

James
25-03-01, 07:57 PM
Hi
Congratulations on the new Buggy, She looks Good
I bought a part built kit on 1 Jan this year and picked it up on 11 Jan and ufortunately my mate who drove me to pick it up bumped into me on the way home
The car was TAxed and MOT`d so I dont have to worry about SVA
Fortunately damage was very light and the Buggy is going in for painting Tommorrow
Your new engine looks a real Monster
Good luck with the rest of the build

Cheers

James