PDA

View Full Version : Steam from dash vents S W Meet



kobra
04-02-07, 09:46 AM
Good mornin Guys. Well i Was on my way up to Kenn this morning, when steam started pumping out of the das vents. checked underneath and water pouring out. Then it stopped. If its the matrix do they normally blow. Or would high pressure blow them . Could i be the water pump not pumping. The temp seems to be running at approx 60/70 . Its pretty cold down here so i would think thats about right. I have now cooled it and topped up the header tank . Started up and got a blast of steam from thn vents . Just got back from a quick run and no steam from vents and no leak. Is there a valve on the heater? Can' see a lot to much stainless steel in the way. So it won't be this month at Kenn. Regards Ray.

Dutch Paul
04-02-07, 02:59 PM
Good mornin Guys. Well i Was on my way up to Kenn this morning, when steam started pumping out of the das vents. checked underneath and water pouring out. Then it stopped. If its the matrix do they normally blow. Or would high pressure blow them . Could i be the water pump not pumping. The temp seems to be running at approx 60/70 . Its pretty cold down here so i would think thats about right. I have now cooled it and topped up the header tank . Started up and got a blast of steam from thn vents . Just got back from a quick run and no steam from vents and no leak. Is there a valve on the heater? Can' see a lot to much stainless steel in the way. So it won't be this month at Kenn. Regards Ray.

Too much pressure in the cooling system will blow the weakest point (normally the rad cap)
Sounds like the heater matrix or loose/damaged hose.
I would get it sorted ASAP if I were you.
I used to get steamed up windows in my tintop whenever I switched the heater on, a tin of Radweld cured it. It will seal a small hole. You say water was pouring out, if so it will be too big a leak for Radweld.
I`m not sure whether I would put Radweld in my P&J though:o

Miket
04-02-07, 03:10 PM
Good mornin Guys. Well i Was on my way up to Kenn this morning, when steam started pumping out of the das vents. checked underneath and water pouring out. Then it stopped. If its the matrix do they normally blow. Or would high pressure blow them . Could i be the water pump not pumping. The temp seems to be running at approx 60/70 . Its pretty cold down here so i would think thats about right. I have now cooled it and topped up the header tank . Started up and got a blast of steam from thn vents . Just got back from a quick run and no steam from vents and no leak. Is there a valve on the heater? Can' see a lot to much stainless steel in the way. So it won't be this month at Kenn. Regards Ray.

Ray

Where was the water coming from, front or somewhere near the heater. :confused: I had a leak on my heater matrix which caused steam through the vents, I used a product called Barr's leak, it has been fine ever since and yes there is an on/off valve on the nearside of the heater, just follow the pipes towards the cockpit and you will find it. :thumb:

Better luck next time getting to the Meeting, it was a good turnout, after the meet we went for blast up to Anthony's in Wellington.

Miket
04-02-07, 03:27 PM
Ray

Some photo's just to make you jealous. :( :D :drive: :thumb:

Clive
04-02-07, 03:55 PM
Hi Ray, how bad was "pouring out"? was it a drip or much more serious? If it was a drip and there was steam for a short while, I would initially suspect condensation on the heater matrix especially if the car has been in a cold damp garage for any length of time. As the engine heats up and the matrix starts to get hot the dampness on the outside of the matrix evaporates and steams off, could it have been this?

kobra
04-02-07, 05:13 PM
Mike the water formed a small puddle on the ground.some water in the cavities on top of gearbox it did'nt take a lot of water when i topped it up. It is right below the heater. The tubes feel dry its difficult to see with the s/s in the way . I will remove the s/s tomorrow so i can have a good look.I took it out again about 1600 hrs and not a drip or steam from the dash vents. And thanks for the photographs it made my day !!!!!!!!!!!!!!!!!!!!!!!!!!!!!

kobra
04-02-07, 05:19 PM
Hi Clive, The garage is not damp i run deumids. i have only done 350 miles and its the first time. I did a 20 mile drive early this evening ad not a drip or steam. Ray

kobra
04-02-07, 05:32 PM
Hi Paul, Thanks for input . Your right i don't want to put radweld in really. im going to have a look see tomorrow when i get the stainless steel out of the way. Received some nice photographs from Miket, Just rubbing it in a bit. looked like they had a good meet. Ray

ps. nice bits on your avitar

Dutch Paul
04-02-07, 05:41 PM
ps. nice bits on your avitar

FFS it`s even spelt properly on her t-shirt :mad: :rotfl:

Purple AK
04-02-07, 05:44 PM
Ray. Just a tangental thought. Had you used the washers prior to the steam appearing? A split washer hose could have caused water to be drawn into the heater blower, and show as water on the gearbox fillets.

kobra
04-02-07, 07:46 PM
Thats interesting, i did fill the washer bottle two days ago and i was'nt impressed with its fire power. Ill check i in the morning. Cheers Ray.

westborne
05-02-07, 06:42 AM
Hi Ray

Sorry you didn't make it - hope the problem is trivial !!

Blasted up the M5 after so that we could all give Anthony much needed advice and support - Must buy him a kettle !!

Bit upset that Kaths hat blew off and Mike T behind didn't swerve enough to catch it !! - Honestly what are mates for ?

Catch up soon - you coming to the Treasure Hunt on the 25th ?

Watch the SW forum for upddated news !

Neil O
05-02-07, 09:30 AM
Harrison managed to catch one of my gloves as it flew out of the glove box. :thumb:
That run up to Antony's seemed to eat my fuel, not sure why though. ;)

Neil O
05-02-07, 09:33 AM
Ray, don't be too concerned if your washer jets are a bit weak. If you have production car powered ones you'll just be wiping it out of your eyes! :D

westborne
05-02-07, 02:54 PM
Mike

Just realised where Martin L's car was

in your first photo

- it was in the container ! - didnt want to get salt on it !!!

Miket
05-02-07, 03:02 PM
Mike

Just realised where Martin L's car was

in your first photo

- it was in the container ! - didnt want to get salt on it !!!

http://smileys.smileycentral.com/cat/36/36_1_55.gif

westborne
05-02-07, 03:24 PM
Sorry Mike T

apart from quoting me - couldnt see what your latest merry quip was ?

Miket
05-02-07, 03:30 PM
Sorry Mike T

apart from quoting me - couldnt see what your latest merry quip was ?

Its a clapping smiley, can you not see it, I can. :confused: :confused:

kobra
05-02-07, 09:42 PM
Hi Ray

Sorry you didn't make it - hope the problem is trivial !!

Blasted up the M5 after so that we could all give Anthony much needed advice and support - Must buy him a kettle !!

Bit upset that Kaths hat blew off and Mike T behind didn't swerve enough to catch it !! - Honestly what are mates for ?

Catch up soon - you coming to the Treasure Hunt on the 25th ?

Watch the SW forum for upddated news ! Hi Chris, Yes will be there, just need meeting place and time. Ray

westborne
06-02-07, 06:55 AM
Hi Ray will blast Treasure hunt details soon - here and to SW email list

Mike T- no clapping icon

Some more piccies

Neil O
06-02-07, 10:13 AM
Martin kept up well considering he was towing a fuel tanker..............:D

V8 BJC
06-02-07, 12:26 PM
Thought I was seeing things just now. I thought the black GD was running with my Reg number :eek:

Whose car is that. Looks nice :thumb:

Are those wheels the CHB ones from image with no visible perimeter bolts?

Miket
06-02-07, 12:49 PM
Martin kept up well considering he was towing a fuel tanker..............:D

Matching MG colour aswell :rotfl: :D :thumb:

westborne
06-02-07, 02:51 PM
The black GD is Colin and Bab's car - live near Bickleigh in Devon - Running an LS6 engine I think.

Neil O
06-02-07, 02:53 PM
Thought I was seeing things just now. I thought the black GD was running with my Reg number :eek:

Whose car is that. Looks nice :thumb:

Are those wheels the CHB ones from image with no visible perimeter bolts?

It's Colin's car. He probably won't speak up here, he's shy. :o

I think the wheels are CHB's, couldn't be sure though (no help at all then).

westborne
06-02-07, 02:56 PM
Forgot to mention -

He's also got Heated seats !!!

We try not to let him out to much as he shows the rest of us up too much !!