PDA

View Full Version : RV8 ENGINE MOUNTS



adyv8
05-02-04, 02:06 PM
JUST RECEIVED MY ENGINE MOUNTS FROM PILGRIM,THE TRIANGLE PART THAT BOLTS TO THE BLOCK DOESNT LOOK VERY STRONG,(HOLES DRILLED CLOSE TO EDGE )HAS ANYONE EXPERIENCED ANY PROBS/IS THIS NORMAL?
THANKS;) :f

breskit
05-02-04, 05:30 PM
It's normal and they're strong enough. Don't worry about it.

Cheers,
Tony B
---
http://homepage.ntlworld.com/tony.breski

PrivateVoid
05-02-04, 08:19 PM
Compared to the Ford V6 stands I had before (I was planning on putting a V6 2.9L in there) the Rover V8 engine mounts looks really simple. I haven't seen where they fit on the Rover (I'm still waiting for my Rover V8 3.9L rebuild), but I guess they're suitable for what they will be used for.

Michael

breskit
06-02-04, 11:15 AM
Here's some pics of where they are fitted. Where the engine is sat on the trolley, you can see where the brackets bolt in.

http://homepage.ntlworld.com/tony.breski/images/shortengine.jpg
http://homepage.ntlworld.com/tony.breski/images/startermotor.jpg

Cheers,
Tony B
---
http://homepage.ntlworld.com/tony.breski

milner
06-02-04, 12:26 PM
You may need to file out the holes slightly as my bracket didn't line up with the engine holes.

Also watch out for the starter motor as Tony's pic shows. I was unlucky in the fact I had a larger starter motor which meant the electrical connections rested on the engine mount, hence earthed !

I agree, the bracket does look a bit flimsy. I've only found one example of a fail though, check out the link for a photo.

http://www.cobraclub.com/crcforum/user_files/356.jpg

I decided to fit it and worry about it as an when it does fail.

Jon

breskit
06-02-04, 03:45 PM
Jon,

If that _IS_ your plate with the crack in it, I'd replace it PDQ!

Tony B
---
http://homepage.ntlworld.com/tony.breski

milner
09-02-04, 08:58 AM
Fortunately not !

My car is still in two bits, shell at my house - chassis at dads.

I spotted this pic whilst trying to figure out which holes to use, but I agree with the earlier thread - they do seem weak and the bolts are, I feel, too close to the edge of the plate.

On mine I have about 5mm between the bolt hole and the edge. I've used a large washer on both sides to try and spread some of the load. I really don't fancy having to change one of these mounts at a later date.

In hind sight, I wish I'd had them strengthened before fitting the engine in.

JOn