PDA

View Full Version : Piston Broke



tonym
11-07-04, 01:32 PM
I have now taken all the pistons out of the block. One was brand new, of the other 7, the knackered one had no top ring at all, 6 had broken top rings and only one had a complete top ring.:( There is signs of detonation on 3-4 pistons (easily seen now they're out) would this cause the ring failure or has something else caused it?:confused: I have no idea of the history of the engine and this is the first time i've done any major work to the engine.

wilf
11-07-04, 11:07 PM
Tony - like I said elsewhere, you have to track down the root cause of this failure and cure it in your rebuild.

The CR you were running would be a likely starting point, plus of course, do you know what a/f ratio you had?

Piston/bore clearances and ring gaps need to be spot on.

Difficult to know if your problem started with detonation or too-small ring gaps.

Just re-build it right.

If you are lacking the knowledge yourself, ( and don't take that as any kind of insult please)maybe invest in a short block or short block rebuild from a known RV8 engine supplier???

TINKA
11-07-04, 11:44 PM
Hi Tony, after seeing that broken piston in the flesh yesterday :eek: and reading your description of the other pistons when you took them out, I would say it was most likely detonation due to the compression being a bit on the high side. I am sure when you take the pistons to have their conrods removed and fitted to the new pistons they will confirm this. Just make sure you take your time and carefully gap the new rings when you fit them. :)

tonym
11-07-04, 11:48 PM
I should get the pistons back with the conrods fitted tomorrow dinnertime and the first job will be to gap the rings. I'll let you know how it goes :)