Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Ak horn problem

  1. #11
    Join Date
    Mar 2010
    Location
    Highlands (North of Inverness)
    Posts
    1,243
    Ditto those guys with a switch/ push button on the dash (don't forget it needs the horn symbol for IVA). I got extremely peeved (polite version) at trying to get the bloody thing to work properly and in the end went old school and it now works great.
    Best anti speeding device - a rear view mirror with a police car in it.
    A pedestrian - someone who thought there was still a couple of gallons in the tank.
    AK Chassis and body collected 12.12.14

  2. #12
    Join Date
    Mar 2009
    Location
    liverpool
    Age
    46
    Posts
    407
    this is the solution!!!

    download.jpg

    will it need a sticker for IVA???

  3. #13
    Join Date
    May 2014
    Location
    Birmingham
    Age
    43
    Posts
    768
    Quote Originally Posted by philbrad73 View Post
    this is the solution!!!

    download.jpg

    will it need a sticker for IVA???

    HaHa, Yes! My dad actually brought me one of those as a joke one Christmas for a previous kit-car!

    Alan.
    AK Gen II on the road Jan '19
    GM LQ4 364ci, LS9 cam, Omex 710.
    Tremec T56 Terminator.
    3.27:1 Powr-lok LSD

  4. #14
    Join Date
    Apr 2012
    Location
    Wrexham
    Age
    48
    Posts
    546
    Same problem here and relay fixed the problem for me too.
    Reg
    Gav
    AK Ls1/t56
    Body on April 2014
    Passed IVA March 2017
    Registered April 2017.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •