Results 1 to 5 of 5

Thread: Rev counter

  1. #1
    Join Date
    Oct 2015
    Location
    helmshore
    Age
    50
    Posts
    55

    Rev counter

    Hi all,just about driven 100 miles and my Smith's classic rev counter has stopped working,not pulled my dash out yet,just wondering if anybody has had failures
    A K Gen 1 small block ford

  2. #2
    Join Date
    Jan 2015
    Location
    Paignton Devon
    Posts
    320
    Need a bit more info, ie what is it driven off, coil or ECU or alternator, it could be something as simple as a wire falling off a connector or a broken/ melted wire
    Last edited by rpm015; 05-09-19 at 10:47 PM.

  3. #3
    Join Date
    Oct 2015
    Location
    helmshore
    Age
    50
    Posts
    55
    Hi just pulled the dash out,all wires seem ok live feed and earth etc the only test left is the trigger wire from the coil. Not sure what the test should be ?

  4. #4
    Join Date
    Jan 2015
    Location
    Paignton Devon
    Posts
    320
    Assuming the engine is running ok so the coil is good there's not much to test, just a continuity test to make sure the wire is intact, after that you have to be looking at the rev counter internals, I assume you've checked the live feed with a multi meter to make sure you're getting a 12v feed?, does it run through a relay?
    Last edited by rpm015; 10-09-19 at 10:15 PM.

  5. #5
    Join Date
    Aug 2004
    Location
    Christchurch, NZ
    Age
    58
    Posts
    2,290
    Trigger wire should read more than 0V and probably less than 12V using a multimeter and engine running. If it is quite possible to get a bit of a shock off that wire so best not handle it while running!
    Cheers

    Myles D-W

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •