Results 1 to 3 of 3
  1. #1
    Join Date
    Feb 2007
    Location
    Essex, UK
    Posts
    4,132

    Stiff clutch when hot

    In My Hawk (302, T5, hyd clutch) the clutch is absolutely fine until the car gets stinking hot then it gets pretty stiff and pushes down in a series of “jerks”
    I’ve recently enclosed the clutch line in a proper heat resistant sleeve and blue the clutch to ensure all new fluid, but it doesn’t seem to have made any difference. Any suggestions? I think my next step may be to protect the slave cyl from excess heat somehow. Has anybody had similar issues and solved them?
    Thanks, any advice appreciated.
    Simon
    WARNING: Translation of author's random thoughts may have resulted in the unintended introduction of grammatical errors, typos, technical inaccuracies, lies, propaganda, rhetoric, blasphemy, rambling, and/or exhibition of shocking levels of ignorance.

  2. #2
    Join Date
    Aug 2007
    Location
    Bournemouth
    Posts
    691
    Have you looked at your pedal assembly? I have no idea how the pedal assembly is made or built but if you have any Teflon bushes in the set up then they could be the problem. Silicon spray or dashboard back to black may sort that out if it’s the culprit.
    David.

    Life is driving the Cobra. The rest of the time is just waiting................till I fix it!

    Wessex region caretaker rep.

  3. #3
    Join Date
    Feb 2007
    Location
    Essex, UK
    Posts
    4,132
    I’ll certainly give it a squirt, it’s a tilton setup so not sure what bushes it uses.
    simon
    WARNING: Translation of author's random thoughts may have resulted in the unintended introduction of grammatical errors, typos, technical inaccuracies, lies, propaganda, rhetoric, blasphemy, rambling, and/or exhibition of shocking levels of ignorance.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •