Results 1 to 5 of 5
  1. #1
    Join Date
    Nov 2002
    Location
    Westonzoyland, Somerset, England.
    Posts
    237

    No Oil Pressure !!

    Oh dear, not my weekend..

    I tried priming the oil pump on my RV8, just as everyone has told me , packed with vasaline and used the RPI tool in the end of my drill.

    With the rocker box off, I had a very, very small flow of oil, not enough to turn off the oil light.

    After nearly buring out my drill, I removed the filter and gave the drill a brief spin and oil + vasaline shot over the garage floor.

    Put the filter back on on now not even the small dribble I had before..

    any idea's ??


  2. #2
    Join Date
    May 2003
    Location
    Bridgnorth, Shropshire.
    Age
    57
    Posts
    2,989

    RE: No Oil Pressure !!

    do you have a remote filter housing, or is this a standard RV8 filter in the block?
    Steve
    DAX 383 ci SBC 440hp...SOLD
    GD Euro mk4, 427 C.I. LS7, 540 hp...SOLD
    Project Tango "Old School" GD, 440 hp LS3 ....SOLD
    460 HP LS Griff "a gentlemens cobra"....SOLD
    630 HP LS7 TVR Tamora

  3. #3
    Join Date
    Nov 2002
    Location
    Westonzoyland, Somerset, England.
    Posts
    237

    RE: No Oil Pressure !!

    I have the normal Rover pump/filter setup.

    I have now removed the pump, (bugger to get those little star screws undone), anyway looking inside the cover housing I saw that the relief valve was stuck fully open, I could even see the end as it hadn't entered it's bore.

    Just touched it with the screwdriver, and it shot home like a ferret down a hole. Hopefully that was the problem, but I have no more Vaseline left, will try again tomorrow night.

    Steve

    :}

  4. #4
    Join Date
    May 2004
    Location
    Finchampstead, Berkshire, UK.
    Age
    55
    Posts
    3,776

    RE: No Oil Pressure !!

    Steve,

    Make sure that the hoses are not switched around the wrong way if you are using a remote filter, it's very easy to do and you will end up with zero circulation due to the valve inside the oil filter. Can't remember which way round they go but I can have a look tonight if you like

    Cheers

    Jim
    GD Mk3 Jag based
    Supercharged LS1
    GD J1M

  5. #5
    Join Date
    Nov 2002
    Location
    Westonzoyland, Somerset, England.
    Posts
    237

    RE: No Oil Pressure !!

    re-packed the pump with Vaseline, re-fitted and primed again with the drill, oil light immediately went out and pressure gauge rose up to 50 ish with my knackered drill.

    Oil light now goes out just by turning over on the starter. Pressure relief valve was the problem. I was also surprised not to see loads of oil squirting out from the rockers covering my garage wall like I am used to with a 4 cylinder OHC. Seems Rovers just sort of squeeze the oil out more sedately.

    Anyway happy now, time to sort the ignition out..


    Steve

    :tu :tu

Similar Threads

  1. Oil Pressure
    By chiffer in forum General Tech Tips & Questions
    Replies: 7
    Last Post: 08-11-05, 03:11 PM
  2. Oil Pressure
    By rick turner in forum General Cobra Discussion
    Replies: 2
    Last Post: 21-09-05, 12:18 AM
  3. Oil pressure Take-off
    By Goldie in forum General Tech Tips & Questions
    Replies: 6
    Last Post: 07-05-05, 10:25 AM
  4. Oil Pressure
    By marc davis in forum Newbies
    Replies: 4
    Last Post: 02-05-05, 11:37 PM
  5. Oil Pressure
    By ss083 in forum General Tech Tips & Questions
    Replies: 3
    Last Post: 23-09-02, 04:40 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •